Как из одной базы 1С:Предприятие 8 перенести остатки товаров в другую базу,

Как из одной базы 1С:Предприятие 8 перенести остатки товаров в другую базу, используя COM-соединение.

Запрос = Новый Запрос; 
Запрос.Текст= "ВЫБРАТЬ 
|	ОстаткиТоваровОрганизацийОстатки.Организация КАК Организация, 
|	ОстаткиТоваровОрганизацийОстатки.Номенклатура, 
|	ОстаткиТоваровОрганизацийОстатки.ГТДОрганизации, 
|	ОстаткиТоваровОрганизацийОстатки.СтранаПроисхождения, 
|	ОстаткиТоваровОрганизацийОстатки.Комиссионер, 
|	ОстаткиТоваровОрганизацийОстатки.КоличествоОстаток 
|ИЗ 
|	РегистрНакопления.ОстаткиТоваровОрганизаций.Остатки(&ДатаПереноса, ) КАК ОстаткиТоваровОрганизацийОстатки 
|ИТОГИ ПО 
|	Организация"; 

Запрос.УстановитьПараметр("ДатаПереноса", ДатаПереноса); 

V8 = Новый COMОбъект("V8.ComConnector"); 
Попытка 
	Открытие = V8.Connect("File=""" + Путь + """;Usr=""Usr1"";"); 
Исключение 
	Предупреждение("База данных не открыта!!!"); 
	Возврат; 
КонецПопытки; 

Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам); 
МенеджерДокумента = Открытие.Документы.ОприходованиеТоваров; 
МенеджерНоменклатуры = Открытие.Справочники.Номенклатура; 
МенеджерОрганизаций = Открытие.Справочники.Организации; 

// Менеджеры остальных справочников:  

Пока Выборка.Следующий() Цикл 
	Документ = МенеджерДокумента.СоздатьДокумент(); 
	Код = Выборка.Организация.Код; 
	Организация = МенеджерОрганизаций.НайтиПоКоду(Код); 
	Если Организация.Пустая() Тогда 
		Организация = МенеджерОрганизаций.СоздатьЭлемент(); 
		Организация.Код = Код; 

		// Остальные реквизиты: 

		Организация.Записать(); 
	КонецЕсли; 

	// Обработка остальных реквизитов, справочников: 

	ВыборкаПодчиненная = Выборка.Выбрать(); 
	Пока ВыборкаПодчиненная.Следующий() Цикл 

		// Поиск/перенос данных справочников 
		// заполнение табличной части документа 

	КонецЦикла; 

	Документ.Записать(РежимЗаписиДокумента.Проведение); 

КонецЦикла; 

 

15.12.2018